<!DOCTYPE html>
<html lang="en" dir="ltr" prefix="content: http://purl.org/rss/1.0/modules/content/  dc: http://purl.org/dc/terms/  foaf: http://xmlns.com/foaf/0.1/  og: http://ogp.me/ns#  rdfs: http://www.w3.org/2000/01/rdf-schema#  schema: http://schema.org/  sioc: http://rdfs.org/sioc/ns#  sioct: http://rdfs.org/sioc/types#  skos: http://www.w3.org/2004/02/skos/core#  xsd: http://www.w3.org/2001/XMLSchema# ">
<head>
<meta charset="utf-8" />
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-26466179-5"></script>
<script>window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments)};gtag("js", new Date());gtag("config", "UA-26466179-5", {"groups":"default","anonymize_ip":true,"allow_ad_personalization_signals":false});</script>
<link rel="canonical" href="https://www.highlandsnews.com/obituaries/randall-forrest-simmons" />
<meta name="description" content="Randall Forrest Simmons, 74, of Highlands, passed away on Wednesday, April 1, 2020. 

A private service will be held at Goldmine Baptist Church. " />
<meta name="Generator" content="Drupal 8 (https://www.drupal.org)" />
<meta name="MobileOptimized" content="width" />
<meta name="HandheldFriendly" content="true" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<script type="text/javascript">
// Initialize the google variables.
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
// Add a place to store the slot name variable.
googletag.slots = googletag.slots || {};
(function() {
  var useSSL = "https:" == document.location.protocol;
  var src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
  document.write('<scr' + 'ipt src="' + src + '"></scr' + 'ipt>');
})();
</script>
<script type="text/javascript">
  
  googletag.slots["cni_highlandssidebar3"] = googletag.defineSlot("//116205717/CNI-Highlandssidebar3", [300, 250], "js-dfp-tag-cni_highlandssidebar3")

    .addService(googletag.pubads())

  
  
  
      ;
</script>
<script type="text/javascript">
  
  googletag.slots["cni_highlandssidebar2"] = googletag.defineSlot("//116205717/CNI-Highlandssidebar2", [300, 250], "js-dfp-tag-cni_highlandssidebar2")

    .addService(googletag.pubads())

  
  
  
      ;
</script>
<script type="text/javascript">
  
  googletag.slots["cni_highlandssidebar13"] = googletag.defineSlot("//116205717/CNI-Highlandssidebar1", [300, 350], "js-dfp-tag-cni_highlandssidebar13")

    .addService(googletag.pubads())

  
  
  
      ;
</script>
<script type="text/javascript">
  
  googletag.slots["cni_highlandsmarket"] = googletag.defineSlot("//116205717/CNI-Highlandsmarket", [300, 100], "js-dfp-tag-cni_highlandsmarket")

    .addService(googletag.pubads())

  
  
  
      ;
</script>
<script type="text/javascript">
  
  googletag.slots["cni_highlandspromo"] = googletag.defineSlot("//116205717/CNI-Highlandspromo", [300, 100], "js-dfp-tag-cni_highlandspromo")

    .addService(googletag.pubads())

  
  
  
      ;
</script>
<script type="text/javascript">
  
  googletag.slots["cni_highlandsmidhome2"] = googletag.defineSlot("//116205717/CNI-Highlandsmidhome2", [300, 250], "js-dfp-tag-cni_highlandsmidhome2")

    .addService(googletag.pubads())

  
  
  
      ;
</script>
<script type="text/javascript">
  
  googletag.slots["cni_highlandsmidhome"] = googletag.defineSlot("//116205717/CNI-Highlandsmidhome", [300, 250], "js-dfp-tag-cni_highlandsmidhome")

    .addService(googletag.pubads())

  
  
  
      ;
</script>
<script type="text/javascript">
  
  googletag.slots["cni_highlandsleaderboard"] = googletag.defineSlot("//116205717/CNI-Highlandsleaderboard", [[728, 90], [300, 250]], "js-dfp-tag-cni_highlandsleaderboard")

    .addService(googletag.pubads())

  
  
  
      ;
</script>
<script type="text/javascript">
  
  googletag.slots["cni_highlandsbanner"] = googletag.defineSlot("//116205717/CNI-Highlandsbanner", [468, 60], "js-dfp-tag-cni_highlandsbanner")

    .addService(googletag.pubads())

  
  
  
      ;
</script>
<script type="text/javascript">
googletag.cmd.push(function() {
      googletag.pubads().enableAsyncRendering();
        googletag.pubads().enableSingleRequest();
        googletag.pubads().collapseEmptyDivs();
      });
googletag.enableServices();
</script>
<link rel="shortcut icon" href="/sites/highlandsnews.etypegoogle7.com/files/highlanderfav.jpg" type="image/jpeg" />
<link rel="revision" href="https://www.highlandsnews.com/obituaries/randall-forrest-simmons" />
<script>window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};</script>

<title>Randall Forrest Simmons | The Highlander, Highlands, North Carolina</title>
<link rel="stylesheet" media="all" href="/core/assets/vendor/normalize-css/normalize.css?q888sg" />
<link rel="stylesheet" media="all" href="/core/misc/normalize-fixes.css?q888sg" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/ajax-progress.module.css?q888sg" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/align.module.css?q888sg" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/autocomplete-loading.module.css?q888sg" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/fieldgroup.module.css?q888sg" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/container-inline.module.css?q888sg" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/clearfix.module.css?q888sg" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/details.module.css?q888sg" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/hidden.module.css?q888sg" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/item-list.module.css?q888sg" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/js.module.css?q888sg" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/nowrap.module.css?q888sg" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/position-container.module.css?q888sg" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/progress.module.css?q888sg" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/reset-appearance.module.css?q888sg" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/resize.module.css?q888sg" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/sticky-header.module.css?q888sg" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/system-status-counter.css?q888sg" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/system-status-report-counters.css?q888sg" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/system-status-report-general-info.css?q888sg" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/tabledrag.module.css?q888sg" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/tablesort.module.css?q888sg" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/tree-child.module.css?q888sg" />
<link rel="stylesheet" media="all" href="/modules/contrib/poll/css/poll.base.css?q888sg" />
<link rel="stylesheet" media="all" href="/modules/contrib/poll/css/poll.theme.css?q888sg" />
<link rel="stylesheet" media="all" href="/modules/custom/etype/css/etype.css?q888sg" />
<link rel="stylesheet" media="all" href="/modules/custom/etype/modules/etype_login_cni/css/etype_login_cni.css?q888sg" />
<link rel="stylesheet" media="all" href="/modules/contrib/addtoany/css/addtoany.css?q888sg" />
<link rel="stylesheet" media="all" href="/themes/custom/tiempos/node_modules/bulma-0.7.5/css/bulma.min.css?q888sg" />
<link rel="stylesheet" media="all" href="/themes/custom/tiempos/css/base.css?q888sg" />
<link rel="stylesheet" media="all" href="/themes/custom/tiempos/css/regions.css?q888sg" />
<link rel="stylesheet" media="all" href="/themes/custom/tiempos/css/typography.css?q888sg" />
<link rel="stylesheet" media="all" href="/themes/custom/tiempos/css/navigation.css?q888sg" />
<link rel="stylesheet" media="all" href="/themes/custom/tiempos/css/helpers.css?q888sg" />
<link rel="stylesheet" media="all" href="/themes/custom/tiempos/css/views.css?q888sg" />
<link rel="stylesheet" media="all" href="/themes/custom/tiempos/css/blocks.css?q888sg" />
<link rel="stylesheet" media="all" href="/themes/custom/tiempos/css/content.css?q888sg" />
<link rel="stylesheet" media="all" href="/themes/custom/tiempos/css/flexslider.css?q888sg" />
<link rel="stylesheet" media="all" href="/themes/custom/tiempos/css/ads.css?q888sg" />
<link rel="stylesheet" media="all" href="/themes/custom/tiempos/css/sites.css?q888sg" />
<link rel="stylesheet" media="all" href="/themes/custom/tiemposcni/site.css?q888sg" />
<link rel="stylesheet" media="all" href="/core/themes/classy/css/components/action-links.css?q888sg" />
<link rel="stylesheet" media="all" href="/core/themes/classy/css/components/breadcrumb.css?q888sg" />
<link rel="stylesheet" media="all" href="/core/themes/classy/css/components/button.css?q888sg" />
<link rel="stylesheet" media="all" href="/core/themes/classy/css/components/collapse-processed.css?q888sg" />
<link rel="stylesheet" media="all" href="/core/themes/classy/css/components/container-inline.css?q888sg" />
<link rel="stylesheet" media="all" href="/core/themes/classy/css/components/details.css?q888sg" />
<link rel="stylesheet" media="all" href="/core/themes/classy/css/components/exposed-filters.css?q888sg" />
<link rel="stylesheet" media="all" href="/core/themes/classy/css/components/field.css?q888sg" />
<link rel="stylesheet" media="all" href="/core/themes/classy/css/components/form.css?q888sg" />
<link rel="stylesheet" media="all" href="/core/themes/classy/css/components/icons.css?q888sg" />
<link rel="stylesheet" media="all" href="/core/themes/classy/css/components/inline-form.css?q888sg" />
<link rel="stylesheet" media="all" href="/core/themes/classy/css/components/item-list.css?q888sg" />
<link rel="stylesheet" media="all" href="/core/themes/classy/css/components/link.css?q888sg" />
<link rel="stylesheet" media="all" href="/core/themes/classy/css/components/links.css?q888sg" />
<link rel="stylesheet" media="all" href="/core/themes/classy/css/components/menu.css?q888sg" />
<link rel="stylesheet" media="all" href="/core/themes/classy/css/components/more-link.css?q888sg" />
<link rel="stylesheet" media="all" href="/core/themes/classy/css/components/pager.css?q888sg" />
<link rel="stylesheet" media="all" href="/core/themes/classy/css/components/tabledrag.css?q888sg" />
<link rel="stylesheet" media="all" href="/core/themes/classy/css/components/tableselect.css?q888sg" />
<link rel="stylesheet" media="all" href="/core/themes/classy/css/components/tablesort.css?q888sg" />
<link rel="stylesheet" media="all" href="/core/themes/classy/css/components/tabs.css?q888sg" />
<link rel="stylesheet" media="all" href="/core/themes/classy/css/components/textarea.css?q888sg" />
<link rel="stylesheet" media="all" href="/core/themes/classy/css/components/ui-dialog.css?q888sg" />
<link rel="stylesheet" media="all" href="/core/themes/classy/css/components/messages.css?q888sg" />
<link rel="stylesheet" media="all" href="/core/themes/classy/css/components/node.css?q888sg" />
<link rel="stylesheet" media="all" href="//fonts.googleapis.com/css?family=Petrona" />
<link rel="stylesheet" media="all" href="//fonts.googleapis.com/css?family=Lato" />


<!--[if lte IE 8]>
<script src="/core/assets/vendor/html5shiv/html5shiv.min.js?v=3.7.3"></script>
<![endif]-->
<script src="/modules/custom/etype/js/ada_compliance.js?v=8.8.5"></script>


</head>
<body class="path-node page-node-type-article highlandsnews">
<a href="#main-content" class="visually-hidden focusable skip-link">
    Skip to main content
</a>

  <div class="dialog-off-canvas-main-canvas" data-off-canvas-main-canvas>
    
<div class="layout-container">
  <div class="container is-widescreen">
    
    <header role="banner" class="columns">
        <div class="region region-header-left column">
    <div id="block-tiemposcni-date" class="block block-etype block-date-block">
  
    
      
<p class="is-size-7">April 10, 2020</p>
<div><a role="button" class="navbar-burger is-hidden-desktop" aria-label="menu" aria-expanded="false"><i class="fas fa-bars"></i></a></div>
    
    <div role="search" class="block block-search container-inline">
  <form class="search-block-form" data-drupal-selector="search-block-form" action="/search/node" method="get"
        accept-charset="UTF-8" data-drupal-form-fields="search-edit-keys">
      <div class="search-edit-submit">
          <input class="fas fa-search js-form-submit form-submit" data-drupal-selector="search-edit-submit"
                 type="submit" value="Search" />
      </div>
      <input title="Enter the terms you wish to search for." data-drupal-selector="search-edit-keys" type="search"
             name="keys" value="" size="15" maxlength="128" class="form-search is-really-invisible">
  </form>
</div>
  </div>
<div id="block-extendedsearch" class="block block-block-content block-block-content19db4b1e-4212-4bb2-838b-bd6bd2325075">
  
    
      
            <div class="clearfix text-formatted field field--name-body field--type-text-with-summary field--label-hidden field__item"><p><a href="https://highlandsnews.newsbank.com/">Extended Search</a></p></div>
      
  </div>

  </div>

        <div class="region region-header-center column">
    <div id="block-tiemposcni-branding" class="block block-system block-system-branding-block">
  
    
        <a href="/" title="Home" rel="home" class="site-logo">
      <img src="/sites/highlandsnews.etypegoogle7.com/files/thehighlandernewslogo_0.png" alt="The Highlander, Highlands, North Carolina Home" />
    </a>
  </div>

  </div>

        <div class="region region-header-right column">
      
        <div class="user-menu navbar-menu is-active is-paddingless is-shadowless is-hidden-touch">
            <a href="https://etypeservices.com/ReadTheEdition.aspx?Username=mjohn99213&amp;Pub=3486&amp;PType=hIgHLnds3486typesfjXZ5" target="_blank" id="etype_login_cni_e_edition" class="button has-text-white-ter has-background-black-bis is-uppercase is-size-7 is-sans-serif">E-edition</a>
            <a href="https://www.etypeservices.com/Subscriber/SignIn.aspx?IssueID=213489&amp;ReturnUrl=https%3A//www.etypeservices.com/Subscriber/ReSubscribe.aspx%3FPubID%3D3486" class="button has-text-white-ter has-background-black-bis is-uppercase is-size-7 is-sans-serif">Renew</a>
            <a href="/etype-login" class="button has-text-white-ter has-background-black-bis is-uppercase is-size-7 is-sans-serif" data-drupal-link-system-path="etype-login">Log In</a>
            <a href="/user/login" class="button has-text-white-ter has-background-black-bis is-uppercase is-size-7 is-sans-serif" data-drupal-link-system-path="user/login">Log in</a>
            <a href="https://etypeservices.com/The%20Highlander%20(NC)ID614/default.aspx?PubID=3486" target="_blank" id="etype_login_cni_subscribe" class="button has-text-white-ter has-background-black-bis is-uppercase is-size-7 is-sans-serif">Subscribe</a>
        </div>
  





  </div>

    </header>

    
      <div class="region region-navigation columns">
      <nav role="navigation" id="main-nav" aria-label="user navigation" class="column">
    <div class="navbar">
                <div class="navbar-start is-really-invisible columns">
            <div class="column">
                                <a role="button" class="navbar-burger is-active" aria-label="menu" aria-expanded="false"><i class="fas fa-times"></i></a>
                                <div role="search" class="block block-search container-inline">
  <form class="search-block-form" data-drupal-selector="search-block-form" action="/search/node" method="get"
        accept-charset="UTF-8" data-drupal-form-fields="search-edit-keys">
      <div class="search-edit-submit">
          <input class="fas fa-search js-form-submit form-submit" data-drupal-selector="search-edit-submit"
                 type="submit" value="Search" />
      </div>
      <input title="Enter the terms you wish to search for." data-drupal-selector="search-edit-keys" type="search"
             name="keys" value="" size="15" maxlength="128" class="form-search is-really-invisible">
  </form>
</div>
                <div id="mobile-nav">
                                                                <a href="/" class="navbar-item" data-drupal-link-system-path="&lt;front&gt;">Home</a>
                                                                    <a href="https://www.etypeservices.com/The%20Highlander%20(NC)ID614/" class="navbar-item">E-Edition</a>
                                                                                                        <a href="/magazines" class="navbar-item" data-drupal-link-system-path="magazines">Magazines</a>
                                            
                                                                    <a href="/local" class="navbar-item" data-drupal-link-system-path="taxonomy/term/84">Local</a>
                                                                                                        <a href="/opinion" class="navbar-item" data-drupal-link-system-path="taxonomy/term/3">Opinion</a>
                                                    <a href="/obituaries" class="navbar-item" data-drupal-link-system-path="taxonomy/term/4">Obituaries</a>
                                            
                                                                    <a href="/regional" class="navbar-item" data-drupal-link-system-path="taxonomy/term/83">Regional</a>
                                                                    <a href="/sports" class="navbar-item" data-drupal-link-system-path="taxonomy/term/2">Sports</a>
                                                                    <a href="/classified" class="navbar-item" data-drupal-link-system-path="classified">Classified</a>
                                                                                                        <a href="https://classadz.vdata.com/CommunityNewspapersFranklin/Advertising/Advertiser" class="navbar-item">Place a classified</a>
                                            
                                                                    <a href="/classified/legals" class="navbar-item" data-drupal-link-system-path="taxonomy/term/5">Legals</a>
                                                                    <a href="/webforms" class="navbar-item" data-drupal-link-system-path="webforms">Webforms</a>
                                                                                                        <a href="/about" class="navbar-item" data-drupal-link-system-path="node/969">About Us</a>
                                                    <a href="/contact" class="navbar-item" data-drupal-link-system-path="contact">Contact</a>
                                                    <a href="/archives" class="navbar-item" data-drupal-link-system-path="node/973">Archive</a>
                                            
                                                                    <a href="/advertise" class="navbar-item" data-drupal-link-system-path="node/971">Advertise</a>
                                                                    <a href="https://highlandsnc.org/cam" class="navbar-item">Webcam</a>
                                                                    <a href="https://www.etypeservices.com/The%20Highlander%20(NC)ID614/default.aspx?PubID=3486" class="navbar-item">Subscribe</a>
                                                                                </div>
            </div>
            <div class="column">
                <div class="block block-system block-system-branding-block">
  
    
        <a href="/" title="Home" rel="home" class="site-logo">
      <img src="/sites/highlandsnews.etypegoogle7.com/files/thehighlandernewslogo_0.png" alt=" Home" />
    </a>
  </div>

            </div>
            <div class="column">&nbsp;</div>
        </div>
                <div id="main-navbar-menu" class="navbar-menu has-text-weight-semibold">
                                                                                                                                                                <a href="/" class="navbar-item" data-drupal-link-system-path="&lt;front&gt;">Home</a>
                                                                                                                                                    <div class="dropdown is-hoverable">
                            <div class="dropdown-trigger">
                                <a href="https://www.etypeservices.com/The%20Highlander%20(NC)ID614/" class="navbar-item">E-Edition</a>
                            </div>
                            <div class="dropdown-menu" role="menu">
                                <div class="dropdown-content">
                                                                                                                                                                            <a href="/magazines" class="navbar-item" data-drupal-link-system-path="magazines">Magazines</a>
                                                                                                    
                                </div>
                            </div>
                        </div>
                                                                                                                                                    <div class="dropdown is-hoverable">
                            <div class="dropdown-trigger">
                                <a href="/local" class="navbar-item" data-drupal-link-system-path="taxonomy/term/84">Local</a>
                            </div>
                            <div class="dropdown-menu" role="menu">
                                <div class="dropdown-content">
                                                                                                                                                                            <a href="/opinion" class="navbar-item" data-drupal-link-system-path="taxonomy/term/3">Opinion</a>
                                                                                                                                                            <a href="/obituaries" class="navbar-item" data-drupal-link-system-path="taxonomy/term/4">Obituaries</a>
                                                                                                    
                                </div>
                            </div>
                        </div>
                                                                                                                                                            <a href="/regional" class="navbar-item" data-drupal-link-system-path="taxonomy/term/83">Regional</a>
                                                                                                                                                            <a href="/sports" class="navbar-item" data-drupal-link-system-path="taxonomy/term/2">Sports</a>
                                                                                                                                                    <div class="dropdown is-hoverable">
                            <div class="dropdown-trigger">
                                <a href="/classified" class="navbar-item" data-drupal-link-system-path="classified">Classified</a>
                            </div>
                            <div class="dropdown-menu" role="menu">
                                <div class="dropdown-content">
                                                                                                                                                                            <a href="https://classadz.vdata.com/CommunityNewspapersFranklin/Advertising/Advertiser" class="navbar-item">Place a classified</a>
                                                                                                    
                                </div>
                            </div>
                        </div>
                                                                                                                                                            <a href="/classified/legals" class="navbar-item" data-drupal-link-system-path="taxonomy/term/5">Legals</a>
                                                                                                                                                    <div class="dropdown is-hoverable">
                            <div class="dropdown-trigger">
                                <a href="/webforms" class="navbar-item" data-drupal-link-system-path="webforms">Webforms</a>
                            </div>
                            <div class="dropdown-menu" role="menu">
                                <div class="dropdown-content">
                                                                                                                                                                            <a href="/about" class="navbar-item" data-drupal-link-system-path="node/969">About Us</a>
                                                                                                                                                            <a href="/contact" class="navbar-item" data-drupal-link-system-path="contact">Contact</a>
                                                                                                                                                            <a href="/archives" class="navbar-item" data-drupal-link-system-path="node/973">Archive</a>
                                                                                                    
                                </div>
                            </div>
                        </div>
                                                                                                                                                            <a href="/advertise" class="navbar-item" data-drupal-link-system-path="node/971">Advertise</a>
                                                                                                                                                            <a href="https://highlandsnc.org/cam" class="navbar-item">Webcam</a>
                                                                                                                                                            <a href="https://www.etypeservices.com/The%20Highlander%20(NC)ID614/default.aspx?PubID=3486" class="navbar-item">Subscribe</a>
                                                                                                    
                    </div>
                <div class="navbar-end">
              <a href="https://www.facebook.com/TheHighlanderNewspaper/" class="has-text-grey-dark" target="_blank" aria-label="Facebook"><i class="fab fa-facebook is-size-3"></i><span class="sr-only">facebook</span></a>

        </div>
    </div>
</nav>




  </div>

    
      <div class="region region-leaderboard">
    <div id="block-dfptagcnihighlandsbanner" class="block block-dfp block-dfp-ada6747079-e6a4-456c-88d2-197e6d701157">
  
    
      <div id="js-dfp-tag-cni_highlandsbanner">
        <script type="text/javascript">
        googletag.cmd.push(function() {
            googletag.display('js-dfp-tag-cni_highlandsbanner');
        });
    </script>
</div>

  </div>
<div id="block-dfptagcnihighlandsleaderboard" class="block block-dfp block-dfp-ad7c1cf5c5-6c8a-407a-b607-50d3b57fcea2">
  
    
      <div id="js-dfp-tag-cni_highlandsleaderboard">
        <script type="text/javascript">
        googletag.cmd.push(function() {
            googletag.display('js-dfp-tag-cni_highlandsleaderboard');
        });
    </script>
</div>

  </div>

  </div>

      <div class="region region-top-content">
    <div data-drupal-messages-fallback class="hidden"></div>

  </div>


    <main role="main" class="columns">
      <a id="main-content" tabindex="-1"></a>
                <div class="region region-content column">
    <div id="block-pagetitle" class="block block-core block-page-title-block">
  
    
      
  <h1 class="title"><span property="schema:name" class="field field--name-title field--type-string field--label-hidden">Randall Forrest Simmons</span>
</h1>


  </div>
<div id="block-tiemposcni-content" class="block block-system block-system-main-block">
  
    
      

<article data-history-node-id="2246" role="article" about="/obituaries/randall-forrest-simmons" typeof="schema:Article" class="node node--type-article node--promoted node--view-mode-full obituaries">
  
      <span property="schema:name" content="Randall Forrest Simmons" class="rdf-meta hidden"></span>


      <footer class="node__meta">
      <article typeof="schema:Person" about="/user/16" class="profile">
  </article>

      <div class="node__submitted">
        <span id="author_id">By </span><a href="/user/16">News Staff</a> on Thursday, April 9, 2020
          <span property="schema:dateCreated" content="2020-04-09T13:08:35+00:00" class="rdf-meta hidden"></span>

      </div>
    </footer>
  
  
  <div class="node__content">
                  
                                    <div class="field">Randall Forrest Simmons, 74, of Highlands, passed away on Wednesday, April 1, 2020. 

A private service will be held at Goldmine Baptist Church. 

Macon Funeral Home is handling the arrangements. …</div>
          <div class="premium_message is-sans-serif"><p>Premium Content is available to subscribers only. Please login&nbsp;<strong><a href="/etype-login">here</a></strong>&nbsp;to access&nbsp;content or go<strong>&nbsp;<a href="https://www.etypeservices.com/The%20Highlander%20(NC)ID614/default.aspx?PubID=3486">here</a></strong>&nbsp;to purchase a subscription.</p>
</div>
        
            </div>

</article>

  </div>
<div id="block-dfptagcnihighlandsmidhome" class="block block-dfp block-dfp-ad7218b3bb-1b04-41a2-9882-bd40fd0e0c9f">
  
    
      <div id="js-dfp-tag-cni_highlandsmidhome">
        <script type="text/javascript">
        googletag.cmd.push(function() {
            googletag.display('js-dfp-tag-cni_highlandsmidhome');
        });
    </script>
</div>

  </div>
<div id="block-dfptagcnihighlandsmidhome2" class="block block-dfp block-dfp-ad41a737f5-d8ff-4b49-9847-85112f208ce0">
  
    
      <div id="js-dfp-tag-cni_highlandsmidhome2">
        <script type="text/javascript">
        googletag.cmd.push(function() {
            googletag.display('js-dfp-tag-cni_highlandsmidhome2');
        });
    </script>
</div>

  </div>

  </div>

      
                <aside class="region region-sidebar column layout-sidebar"  role="complementary">
    <div id="block-dfptagcnihighlandspromo" class="block block-dfp block-dfp-ad65426a62-f820-4fb9-b921-6d2320581bda">
  
    
      <div id="js-dfp-tag-cni_highlandspromo">
        <script type="text/javascript">
        googletag.cmd.push(function() {
            googletag.display('js-dfp-tag-cni_highlandspromo');
        });
    </script>
</div>

  </div>
<div id="block-dfptagcnihighlandsmarket" class="block block-dfp block-dfp-add681951f-76f8-4825-98f4-54a692752cee">
  
    
      <div id="js-dfp-tag-cni_highlandsmarket">
        <script type="text/javascript">
        googletag.cmd.push(function() {
            googletag.display('js-dfp-tag-cni_highlandsmarket');
        });
    </script>
</div>

  </div>
<div id="block-dfptagcnihighlandssidebar1" class="block block-dfp block-dfp-ad6821c8a7-41ab-424b-97a0-63f267c07bfd">
  
    
      <div id="js-dfp-tag-cni_highlandssidebar13">
        <script type="text/javascript">
        googletag.cmd.push(function() {
            googletag.display('js-dfp-tag-cni_highlandssidebar13');
        });
    </script>
</div>

  </div>
<div id="block-weatherwidget-2" class="block block-etype block-weatherwidget-block weatherwidget">
      <iframe style="display: block;" src="https://cdnres.willyweather.com/widget/loadView.html?id=116442" frameborder="0" scrolling="no" title="Weather Widget"></iframe>
  </div>
<div id="block-tiemposcni-etypeeedition" class="block block-etype block-etype-block">
  
    
      <div><a href="https://etypeservices.com/The%20Highlander%20(NC)ID614/" target="_blank" aria-label="The Highlander, Highlands, North Carolina e-Edition"><img src="https://etypeservices.com/LandingPageImages/The%20Highlander%20(NC)/currentpg1.jpg" alt="The Highlander, Highlands, North Carolina e-Edition"></a></div>
<p><a href="https://etypeservices.com/The%20Highlander%20(NC)ID614/" target="_blank" aria-label="The Highlander, Highlands, North Carolina e-Edition">Read The Highlander, Highlands, North Carolina</a></p>

  </div>
<div id="block-dfptagcnihighlandssidebar2" class="block block-dfp block-dfp-ad2d8e4a8b-67ff-4117-9e49-002dcdfcb6a3">
  
    
      <div id="js-dfp-tag-cni_highlandssidebar2">
        <script type="text/javascript">
        googletag.cmd.push(function() {
            googletag.display('js-dfp-tag-cni_highlandssidebar2');
        });
    </script>
</div>

  </div>
<div id="block-tiemposcni-popularcontent" role="navigation" class="block block-statistics block-statistics-popular-block">
  
      <h3 class="section-tag-heading">Popular content</h3>
    
      <div class="item-list"><h3>Today's:</h3><ul><li><a href="/local-news/florida-investigation-leads-cashiers" hreflang="en">Florida investigation leads to Cashiers</a></li><li><a href="/local-news/stay-home" hreflang="en">Stay at home</a></li><li><a href="/local-news/coronavirus-hits-home" hreflang="en">Coronavirus hits home</a></li></ul></div><br /><div class="item-list"><h3>All time:</h3><ul><li><a href="/local-news/florida-investigation-leads-cashiers" hreflang="en">Florida investigation leads to Cashiers</a></li><li><a href="/local-news/coronavirus-hits-home" hreflang="en">Coronavirus hits home</a></li><li><a href="/local-news/stay-home" hreflang="en">Stay at home</a></li></ul></div><br /><div class="item-list"><h3>Last viewed:</h3><ul><li><a href="/obituaries/marjorie-moon-rohrer" hreflang="en">Marjorie Moon Rohrer</a></li><li><a href="/local-news/training-tents-go-hch" hreflang="en">Training tents go up at HCH</a></li><li><a href="/obituaries/william-michael-shoptaw" hreflang="en">William Michael Shoptaw</a></li></ul></div><br />
  </div>
<div id="block-dfptagcnihighlandssidebar3" class="block block-dfp block-dfp-ad6c79e249-085f-40b9-8ba1-8a1ea60bcf61">
  
    
      <div id="js-dfp-tag-cni_highlandssidebar3">
        <script type="text/javascript">
        googletag.cmd.push(function() {
            googletag.display('js-dfp-tag-cni_highlandssidebar3');
        });
    </script>
</div>

  </div>

  </aside>

      
    </main>

    <footer role="contentinfo" class="columns border-top-light">
                <div class="region region-footer-left column">
    <div id="block-tiemposcni-contactinformation" class="block block-block-content block-block-contentbb8e208a-8245-4087-b0c0-a5b20e5a2929">
  
    
      
            <div class="clearfix text-formatted field field--name-body field--type-text-with-summary field--label-hidden field__item"><h3>THE HIGHLANDER</h3>

<p><strong>Phone: </strong>1-828-526-4114 <br />
<strong>Main Fax: </strong>1-828-526-3658 </p>

<p><strong>Address: </strong>PO Box 249, Highlands, NC 28741<br />
<strong>Located: </strong>134 N. Fifth Street, Highlands, NC 28741 <br />
<strong>Hours: </strong>Monday-Friday 8:30am - 5pm</p></div>
      
  </div>

  </div>

                      <div class="region region-footer-center column">
    <div id="block-tiemposcni-copyrightnotice" class="block block-etype block-copyright-block">
  
    
      <p class="has-text-centered">&copy;&nbsp;2020&nbsp;The Highlander, Highlands, North Carolina</p>
  </div>

  </div>

                      <div class="region region-footer-right column">
      
    <ul class="menu footer-menu is-pulled-right">
          <li class="menu-item">
      <a href="https://nearme.highlandsnews.com/" class="button is-size-7 has-text-white-ter has-background-black-bis is-uppercase is-sans-serif">Marketplace</a>
    </li>
          <li class="menu-item">
      <a href="/contact" class="button is-size-7 has-text-white-ter has-background-black-bis is-uppercase is-sans-serif" data-drupal-link-system-path="contact">Contact</a>
    </li>
          <li class="menu-item">
      <a href="/webforms" class="button is-size-7 has-text-white-ter has-background-black-bis is-uppercase is-sans-serif" data-drupal-link-system-path="webforms">Webforms</a>
    </li>
          <li class="menu-item">
      <a href="/about" class="button is-size-7 has-text-white-ter has-background-black-bis is-uppercase is-sans-serif" data-drupal-link-system-path="node/969">About Us</a>
    </li>
          <li class="menu-item">
      <a href="/archives" class="button is-size-7 has-text-white-ter has-background-black-bis is-uppercase is-sans-serif" data-drupal-link-system-path="node/973">Archive</a>
    </li>
          <li class="menu-item">
      <a href="/links" class="button is-size-7 has-text-white-ter has-background-black-bis is-uppercase is-sans-serif" data-drupal-link-system-path="node/1497">Links</a>
    </li>
          <li class="menu-item">
      <a href="/ada-compliance" class="button is-size-7 has-text-white-ter has-background-black-bis is-uppercase is-sans-serif" data-drupal-link-system-path="ada-compliance">Accessibility Policy</a>
    </li>
          <li class="menu-item">
      <a href="/etype-login" class="button is-size-7 has-text-white-ter has-background-black-bis is-uppercase is-sans-serif" data-drupal-link-system-path="etype-login">Login</a>
    </li>
  </ul>
  





  </div>

          </footer>

    <section id="coupons" class="columns">
          </section>

  </div>
</div>
  </div>


<script type="application/json" data-drupal-selector="drupal-settings-json">{"path":{"baseUrl":"\/","scriptPath":null,"pathPrefix":"","currentPath":"node\/2246","currentPathIsAdmin":false,"isFront":false,"currentLanguage":"en"},"pluralDelimiter":"\u0003","suppressDeprecationErrors":true,"google_analytics":{"account":"UA-26466179-5","trackOutbound":true,"trackMailto":true,"trackDownload":true,"trackDownloadExtensions":"7z|aac|arc|arj|asf|asx|avi|bin|csv|doc(x|m)?|dot(x|m)?|exe|flv|gif|gz|gzip|hqx|jar|jpe?g|js|mp(2|3|4|e?g)|mov(ie)?|msi|msp|pdf|phps|png|ppt(x|m)?|pot(x|m)?|pps(x|m)?|ppam|sld(x|m)?|thmx|qtm?|ra(m|r)?|sea|sit|tar|tgz|torrent|txt|wav|wma|wmv|wpd|xls(x|m|b)?|xlt(x|m)|xlam|xml|z|zip"},"statistics":{"data":{"nid":"2246"},"url":"\/core\/modules\/statistics\/statistics.php"},"user":{"uid":0,"permissionsHash":"a9bb809a72593f7676c735244b1ad31eea510cca2f0f7ee6320c17079314de37"}}</script>
<script src="/core/assets/vendor/jquery/jquery.min.js?v=3.4.1"></script>
<script src="/core/assets/vendor/jquery-once/jquery.once.min.js?v=2.2.0"></script>
<script src="/core/misc/drupalSettingsLoader.js?v=8.8.5"></script>
<script src="/core/misc/drupal.js?v=8.8.5"></script>
<script src="/core/misc/drupal.init.js?v=8.8.5"></script>
<script src="https://static.addtoany.com/menu/page.js" async></script>
<script src="/modules/contrib/addtoany/js/addtoany.js?v=8.8.5"></script>
<script src="/libraries/js.cookie.js?v=2.2.0"></script>
<script src="/modules/custom/etype/modules/etype_login_cni/js/etype_login_cni_page.js?v=8.8.5"></script>
<script src="/modules/contrib/google_analytics/js/google_analytics.js?v=8.8.5"></script>
<script src="/themes/custom/tiempos/js/theme.js?v=8.8.5"></script>
<script src="//use.fontawesome.com/releases/v5.8.1/js/all.js" defer></script>
<script src="/core/modules/statistics/statistics.js?v=8.8.5"></script>
<script src="/themes/custom/tiempos/js/article.js?v=8.8.5"></script>


</body>
</html>
